summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-26 18:26:04 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-26 18:26:44 +0200
commitc1cab15a5476712a2dcf2dd8cc91b14d955fb9bf (patch)
treecc0829e2f8977488aaa1f728b879498ee8bff0ea
parentb7884ca3ca72b39397ff0abd1154f97b981394cd (diff)
downloadguix-c1cab15a5476712a2dcf2dd8cc91b14d955fb9bf.tar.gz
gnu: Add dvdisaster.
* gnu/packages/cdrom.scm (dvdisaster): New variable.
-rw-r--r--gnu/packages/cdrom.scm44
1 files changed, 42 insertions, 2 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index f881e7ab3a..b5b14c718e 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -20,15 +20,18 @@
 (define-module (gnu packages cdrom)
   #:use-module (guix download)
   #:use-module (guix packages)
-  #:use-module ((guix licenses) #:select (lgpl2.1+ gpl2 gpl3+))
+  #:use-module ((guix licenses) #:select (lgpl2.1+ gpl2 gpl2+ gpl3+))
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages acl)
   #:use-module (gnu packages compression)
+  #:use-module ((gnu packages gettext) #:renamer (symbol-prefix-proc 'gnu:))
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages help2man)
-  #:use-module (gnu packages pkg-config))
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages which))
 
 (define-public libcddb
   (package
@@ -142,3 +145,40 @@ target drive is CDDA capable.  In addition to simple reading, cdparanoia adds
 extra-robust data verification, synchronization, error handling and scratch
 reconstruction capability.")
     (license gpl2))) ; libraries under lgpl2.1
+
+(define-public dvdisaster
+  (package
+    (name "dvdisaster")
+    (version "0.72.4")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "http://dvdisaster.net/downloads/dvdisaster-"
+                                 version ".tar.bz2"))
+             (sha256
+              (base32
+               "0pm039a78h7m9vvjmmjfkl05ii6qdmfhvbypxjbc7j5w82y66is4"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("gettext" ,gnu:gettext)
+       ("gtk+" ,gtk+)
+       ("pkg-config" ,pkg-config)
+       ("which" ,which)))
+    (arguments
+     `(#:tests? #f)) ; no check target
+    (home-page "http://dvdisaster.net/en/index.html")
+    (synopsis "error correcting codes for optical media images")
+    (description "Optical media (CD,DVD,BD) keep their data only for a
+finite time (typically for many years).  After that time, data loss develops
+slowly with read errors growing from the outer media region towards the
+inside.
+
+Dvdisaster stores data on CD/DVD/BD (supported media) in a way that it is
+fully recoverable even after some read errors have developed.  This enables
+you to rescue the complete data to a new medium.
+
+Data loss is prevented by using error correcting codes.  Error correction
+data is either added to the medium or kept in separate error correction
+files.  Dvdisaster works at the image level so that the recovery does not
+depend on the file system of the medium.  The maximum error correction
+capacity is user-selectable.")
+    (license gpl2+)))