summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-05 17:20:59 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-05 23:36:03 +0100
commitc1cc52a2fe1f43c66204d5225a5c5792e2c68068 (patch)
tree1d88e04b8f11718bca5f1160caf2614bd6f8c514
parente6bd8b5e1def33beac3b6b4eb2f1f525f87ad0ea (diff)
downloadguix-c1cc52a2fe1f43c66204d5225a5c5792e2c68068.tar.gz
gnu: librsvg: Incorporate grafted changes.
* gnu/packages/gnome.scm (librsvg): Update to 2.40.21.
[replacement]: Remove.
(librsvg/fixed): Remove variable.
-rw-r--r--gnu/packages/gnome.scm19
1 files changed, 2 insertions, 17 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c77a17cff5..ff077904fc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2057,9 +2057,8 @@ dealing with different structured file formats.")
 
 (define-public librsvg
   (package
-    (replacement librsvg/fixed)
     (name "librsvg")
-    (version "2.40.20")
+    (version "2.40.21")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -2067,7 +2066,7 @@ dealing with different structured file formats.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0ay9himvw1l1swcf3h1312d2iqzfl65kpbfgiyfykgvq7cydvx6g"))))
+                "1fljkag2gr7c4k5mn798lgf9903xslz8h51bgvl89nnay42qjqpp"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
@@ -2124,20 +2123,6 @@ dealing with different structured file formats.")
 library.")
     (license license:lgpl2.0+)))
 
-(define librsvg/fixed
-  (package
-    (inherit librsvg)
-    (name "librsvg")
-    (version "2.40.21")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnome/sources/" name "/"
-                                  (version-major+minor version)  "/"
-                                  name "-" version ".tar.xz"))
-              (sha256
-               (base32
-                "1fljkag2gr7c4k5mn798lgf9903xslz8h51bgvl89nnay42qjqpp"))))))
-
 (define* (computed-origin-method gexp-promise hash-algo hash
                                  #:optional (name "source")
                                  #:key (system (%current-system))