summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-06 14:36:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-07 05:08:59 +0300
commitc21499fce766762de6df840be28f2092ea95bd4c (patch)
treebb8bf0f73a8adfc6bd8a2828276634a4acd983e6
parent92820c17320cc1a936419819ca05ef609c3fe42d (diff)
downloadguix-c21499fce766762de6df840be28f2092ea95bd4c.tar.gz
gnu: julia-prettytables: Update to 2.1.2.
* gnu/packages/julia-xyz.scm (julia-prettytables): Update to 2.1.2.
[arguments]: Rename custom phase 'skip-color-tests to
'skip-tests-manipulating-terminal-display and skip some more tests.
[propagated-inputs]: Add julia-offsetarrays, julia-stringmanipulation.
-rw-r--r--gnu/packages/julia-xyz.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 75b55f1633..bbb8085492 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4860,7 +4860,7 @@ everything from run time algorithm choice to code generation at compile time.")
 (define-public julia-prettytables
   (package
     (name "julia-prettytables")
-    (version "1.0.1")
+    (version "2.1.2")
     (source
       (origin
         (method git-fetch)
@@ -4869,20 +4869,28 @@ everything from run time algorithm choice to code generation at compile time.")
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "1d1sd87kkwbar3l608h0adzws42cwdrmp1idxx7an6mfqcsdrijw"))))
+         (base32 "029niwxgql9rcyx0rxcyhmwkzxciccji4hb59g6752ixam65wxkh"))))
     (build-system julia-build-system)
     (arguments
      (list
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'link-depot 'skip-color-tests
+          (add-after 'link-depot 'skip-tests-manipulating-terminal-display
             (lambda _
               (substitute* "test/text_backend.jl"
-                ((".*colors\\.jl.*") "")))))))
+                ((".*colors\\.jl.*") "")
+                ((".*custom_cells\\.jl.*") ""))
+              (substitute* "test/general.jl"
+                ((".*string\\.jl.*") ""))
+              (substitute* "test/text_backend/issues.jl"
+                (("testset.*161.*begin" all)
+                 (string-append all " return"))))))))
     (propagated-inputs
      (list julia-crayons
            julia-formatting
+           julia-offsetarrays
            julia-reexport
+           julia-stringmanipulation
            julia-tables))
     (home-page "https://github.com/ronisbr/PrettyTables.jl")
     (synopsis "Print data in formatted tables")