summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-17 21:36:25 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-17 22:06:44 +0200
commitc21af659b4e6871b9576278cd5745881c696fd70 (patch)
tree7f36832c0af9c228e699145090de914f90d3520d
parent759aadd46fdc8b9816c33667129d4e9bae310ba7 (diff)
downloadguix-c21af659b4e6871b9576278cd5745881c696fd70.tar.gz
gnu: recutils: Adjust to Bash 4.4.
* gnu/packages/databases.scm (recutils)[arguments]: Add
'set-bash4.4-header-location' phase.
-rw-r--r--gnu/packages/databases.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index b7bd1f0cd6..5219766133 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -405,7 +405,24 @@ pictures, sounds, or video.")
                  #:configure-flags
                  (list (string-append "--with-bash-headers="
                                       (assoc-ref %build-inputs "bash:include")
-                                      "/include/bash"))))
+                                      "/include/bash"))
+
+                 #:phases (modify-phases %standard-phases
+                            (add-before 'build 'set-bash4.4-header-location
+                              (lambda _
+                                (substitute* "bash/Makefile.in"
+                                  ;; Adjust the header search path for Bash
+                                  ;; 4.4 in accordance with 'bash.pc'.
+                                  (("AM_CPPFLAGS = (.*)$" _ rest)
+                                   (string-append "AM_CPPFLAGS = "
+                                                  "-I$(BASH_HEADERS)/include "
+                                                  rest))
+
+                                  ;; Install to PREFIX/lib/bash to match Bash
+                                  ;; 4.4's search path.
+                                  (("^libdir = .*$")
+                                   "libdir = @libdir@/bash\n"))
+                                #t)))))
 
     (native-inputs `(("emacs" ,emacs-minimal)
                      ("bc" ,bc)