summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 14:21:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:35 +0200
commitc255b295b3018aac91e181960b06f3d2f7159a65 (patch)
tree8ed15c67af554f4e95b16788602c0b6e1a87fd2e
parenteb44c8892379c35947184fbe48275e0c3169828c (diff)
downloadguix-c255b295b3018aac91e181960b06f3d2f7159a65.tar.gz
gnu: texlive-abstract: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-abstract!): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[synopsis, description]: Use Texinfo markup.
-rw-r--r--gnu/packages/tex.scm37
1 files changed, 17 insertions, 20 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3914808692..e5fe9ec3e2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13426,27 +13426,24 @@ loading @code{everyshi-2001-05-15}.")
     (license license:lppl1.3c)))
 
 (define-public texlive-abstract
-  (let ((template (simple-texlive-package
-                   "texlive-abstract"
-                   '("doc/latex/abstract/"
-                     "source/latex/abstract/"
-                     "tex/latex/abstract/")
-                   (base32
-                    "1axm78qgrpml09pkh252g1hsjx9c2w7mbdrm9rdl4yqh5ppwq4y9"))))
-    (package
-      (inherit template)
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ #f)
-          "latex/abstract")
-         ((#:build-targets _ #t)
-          #~(list "abstract.ins"))))
-      (home-page "https://ctan.org/pkg/abstract")
-      (synopsis "Control the typesetting of the abstract environment")
-      (description "The abstract package gives you control over the typesetting
-of the abstract environment, and in particular provides for a one column
+  (package
+    (name "texlive-abstract")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/abstract/" "source/latex/abstract/"
+                   "tex/latex/abstract/")
+             (base32
+              "1axm78qgrpml09pkh252g1hsjx9c2w7mbdrm9rdl4yqh5ppwq4y9")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/abstract")
+    (synopsis "Control the typesetting of the @code{abstract} environment")
+    (description
+     "The @code{abstract} package gives you control over the typesetting of
+the @code{abstract} environment, and in particular provides for a one column
 abstract in a two column paper.")
-      (license license:lppl))))
+    (license license:lppl)))
 
 (define-public texlive-breqn
   (let ((template (simple-texlive-package