summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:21:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:54 +0200
commitc25e7e514724cd880ee738fa987245acc192ff3a (patch)
tree7a6b6ffc9c3e2ca43ae968f77a68a9e2515088e8
parent19e844a2a2959e25c9c856434d916b9240a8065e (diff)
downloadguix-c25e7e514724cd880ee738fa987245acc192ff3a.tar.gz
gnu: Add texlive-nostarch.
* gnu/packages/tex.scm (texlive-nostarch): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2b158aa630..fb650af166 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23283,6 +23283,29 @@ Nanjing University, saves the vector logos as TikZ pictures and provides
 a user-friendly interface to display them in documents and beamers.")
     (license license:lppl1.3c)))
 
+(define-public texlive-nostarch
+  (package
+    (name "texlive-nostarch")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bib/nostarch/" "doc/latex/nostarch/"
+                   "makeindex/nostarch/"
+                   "source/latex/nostarch/"
+                   "tex/latex/nostarch/")
+             (base32
+              "06r1nmwg59ai6v2f80ndkwrcz2ssp1g03g3k5mq0wyyzs1rg4m9q")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/nostarch")
+    (synopsis "LaTeX class for No Starch Press")
+    (description
+     "The package provides the official LaTeX style for No Starch Press.
+Provided are a class, a package for interfacing to @code{hyperref} and an
+index style file.  The style serves both for printed and for electronic
+books.")
+    (license license:lppl)))
+
 (define-public texlive-nucleardata
   (package
     (name "texlive-nucleardata")