summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 15:50:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:29 +0200
commitc2d8c28190299249be97f4be96bbd80856392253 (patch)
tree80b70ede8687da49abd33679aac4b3d85cc90e19
parentf251981d3ee0908bf9fcbc387a5d0ea120f4305e (diff)
downloadguix-c2d8c28190299249be97f4be96bbd80856392253.tar.gz
gnu: Add texlive-diffcoeff.
* gnu/packages/tex.scm (texlive-diffcoeff): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a33b77cf85..9775a6f0b6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3019,6 +3019,31 @@ custom derivatives and differential operators.  The options follow
 a consistent naming scheme making them easy to use and understand.")
     (license license:lppl1.3+)))
 
+(define-public texlive-diffcoeff
+  (package
+    (name "texlive-diffcoeff")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/diffcoeff/"
+                   "tex/latex/diffcoeff/")
+             (base32
+              "1n495bkhqixl77w84fyh1qnc18a9cpnwhpkxijwhdjrczcvxyckw")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/diffcoeff")
+    (synopsis "Write differential coefficients easily and consistently")
+    (description
+     "This package allows the easy and consistent writing of ordinary, partial
+and other derivatives of arbitrary (algebraic or numeric) order.  For mixed
+partial derivatives, the total order of differentiation is calculated by the
+package.  Optional arguments allow specification of points of
+evaluation (ordinary derivatives), or variables held constant (partial
+derivatives), and the placement of the differentiand (numerator or appended).
+The package is built on xtemplate and the configurability it enables,
+extending to differentials (including simple line elements) and jacobians.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-dinat
   (package
     (name "texlive-dinat")