summary refs log tree commit diff
diff options
context:
space:
mode:
authorAdonay Felipe Nogueira <adfeno@openmailbox.org>2016-12-03 21:22:56 -0200
committerLudovic Courtès <ludo@gnu.org>2016-12-08 00:28:47 +0100
commitc451474488a2a9497ba4f839b90b0eff643d1945 (patch)
tree599078c637ae2048302093820baf6b111e43da2f
parent35cdc267aee2b6693e5314e9a7140a8e1d04a522 (diff)
downloadguix-c451474488a2a9497ba4f839b90b0eff643d1945.tar.gz
gnu: samba: Don't expect configuration files inside the store.
Fixes <http://bugs.gnu.org/24834>.

* gnu/packages/samba.scm (samba)[arguments]: Add --sysconfdir configure flag.
Add 'disable-etc-samba-directory-creation' phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/samba.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 1706ec3030..913d5f7d98 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -121,11 +122,16 @@ anywhere.")
                        ;; XXX: heimdal not packaged.
                        "--bundled-libraries=com_err"
                        (string-append "--prefix=" out)
+		       "--sysconfdir=/etc"
                        ;; Install public and private libraries into
                        ;; a single directory to avoid RPATH issues.
                        (string-append "--libdir=" libdir)
-                       (string-append "--with-privatelibdir=" libdir)))))))
-
+                       (string-append "--with-privatelibdir=" libdir))))))
+	 (add-before 'install 'disable-etc-samba-directory-creation
+           (lambda _
+             (substitute* "dynconfig/wscript"
+               (("bld\\.INSTALL_DIRS\\(\"\",[[:blank:]]{1,}\"\\$\\{CONFIGDIR\\}[[:blank:]]{1,}")
+                "bld.INSTALL_DIRS(\"\", \"")))))
        ;; XXX: The test infrastructure attempts to set password with
        ;; smbpasswd, which fails with "smbpasswd -L can only be used by root."
        ;; So disable tests until there's a workaround.