summary refs log tree commit diff
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-11-09 19:38:02 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:44 +0200
commitc470c771edfc077925121162bc8163017efe713b (patch)
treee2b7bf52b3cfa83a4013c11e27de97a4fa86f913
parent5a1042ae32bbc45dfb4dd8255a2e35f9c47a5ea0 (diff)
downloadguix-c470c771edfc077925121162bc8163017efe713b.tar.gz
gnu: Add rust-gix-path-0.10.
* gnu/packages/crates-io.scm (rust-gix-path-0.10): New variable.
(rust-gix-path-0.8): Inherit from rust-gix-path-0.10.

Change-Id: I4ec6102d0f6cf93a93f9998164f8057f622ecd4b
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm38
1 files changed, 29 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 33e3e63e2e..a144e6391d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31237,8 +31237,36 @@ negotiation algorithms.")
 pkt-line serialization format.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-gix-path-0.10
+  (package
+    (name "rust-gix-path")
+    (version "0.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "gix-path" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0fx71d9p7iq4szgrijyw1nj82abg15ylyvaw7kh3l7hp2l0kf7ba"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
+                       ("rust-gix-trace" ,rust-gix-trace-0.1)
+                       ("rust-home" ,rust-home-0.5)
+                       ("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-thiserror" ,rust-thiserror-1))
+       #:cargo-development-inputs (("rust-tempfile" ,rust-tempfile-3))))
+    (home-page "https://github.com/Byron/gitoxide")
+    (synopsis
+     "Part of the Gitoxide project, this crate deals with paths and their conversions")
+    (description
+     "Part of the Gitoxide project, a lean and safe Rust implementation of
+Git.  This crate deals with paths and their conversions")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-gix-path-0.8
   (package
+    (inherit rust-gix-path-0.10)
     (name "rust-gix-path")
     (version "0.8.4")
     (source
@@ -31248,7 +31276,6 @@ pkt-line serialization format.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "0z5733b3z2wbnz1x0y2aq3gpanrhrlrqr4v4gjlqwl68ps69qq0q"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-bstr" ,rust-bstr-1)
@@ -31257,14 +31284,7 @@ pkt-line serialization format.")
         ("rust-once-cell" ,rust-once-cell-1)
         ("rust-thiserror" ,rust-thiserror-1))
        #:cargo-development-inputs
-       (("rust-tempfile" ,rust-tempfile-3))))
-    (home-page "https://github.com/Byron/gitoxide")
-    (synopsis
-     "Crate of the gitoxide project dealing paths and their conversions")
-    (description
-     "This package provides a crate of the gitoxide project dealing paths and their
-conversions.")
-    (license (list license:expat license:asl2.0))))
+       (("rust-tempfile" ,rust-tempfile-3))))))
 
 (define-public rust-gix-prompt-0.5
   (package