summary refs log tree commit diff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2017-09-01 17:19:48 +0100
committerLudovic Courtès <ludo@gnu.org>2017-09-04 15:24:04 +0200
commitc4d4a779238b4a0284f5d835cf03ed5baf28d34c (patch)
treedd2b79fa22f8681e488cfc3e083faad945c69bdd
parent6bd1c41e8729ab5f40620f2acc41dbc630d886de (diff)
downloadguix-c4d4a779238b4a0284f5d835cf03ed5baf28d34c.tar.gz
gnu: pt-scotch32: use keyword arguments from "scotch32"
*gnu/packages/maths.scm (pt-scotch32) [arguments]: substitute keyword
arguments from "scotch32" package, ensuring that the INTSIZE32 macro is
set

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index bebed14b52..d48c31f5e3 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2115,9 +2115,9 @@ YACC = bison -pscotchyy -y -b y
     (propagated-inputs
      `(("openmpi" ,openmpi)))                     ;headers include MPI headers
     (arguments
-     (substitute-keyword-arguments (package-arguments scotch)
-       ((#:phases scotch-phases)
-        `(modify-phases ,scotch-phases
+     (substitute-keyword-arguments (package-arguments scotch32)
+       ((#:phases scotch32-phases)
+        `(modify-phases ,scotch32-phases
            (replace 'build
              (lambda _
                (and