summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-28 16:47:42 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 08:57:56 +0200
commitc548ff6a30705d648e9a704f87001c5090cc8204 (patch)
treeabcc298c6c54751c151ef3a7da10437892071213
parentdbd5612c9045fe1d64ea01ee863163eebbe5748c (diff)
downloadguix-c548ff6a30705d648e9a704f87001c5090cc8204.tar.gz
gnu: python-jaraco-functools: Don't ask to run tests when cross-compiling.
* gnu/packages/python-xyz.scm
(python-jaraco-functools)[arguments]{#:tests?}: When cross-compiling, set to #false.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d5d15bb46c..a78005e011 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8306,7 +8306,7 @@ module with a few extra procedures.")
      (substitute-keyword-arguments
          (package-arguments python-jaraco-functools-bootstrap)
        ((#:tests? _ #f)
-        #t)
+        (not (%current-target-system)))
        ((#:phases phases #~%standard-phases)
         #~(modify-phases #$phases
             (replace 'check