summary refs log tree commit diff
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:44:59 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:27:30 +0200
commitc56a30b3ba3e1e93ced3c6ba2cfb4c738b805074 (patch)
tree533e58ff82ced548a8d59a0cf7eeed56fb9875e0
parent8ecefe72c104222868019a71adb0b9212984169d (diff)
downloadguix-c56a30b3ba3e1e93ced3c6ba2cfb4c738b805074.tar.gz
gnu: Add ghc-time-locale-compat.
* gnu/packages/haskell.scm (ghc-time-locale-compat): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2da2167964..8d4d2b28d9 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9134,4 +9134,24 @@ each constructor are represented using an n-ary product.")
 parser that uses ByteStrings for parsing and representing the URI data.")
     (license license:bsd-3)))
 
+(define-public ghc-time-locale-compat
+  (package
+    (name "ghc-time-locale-compat")
+    (version "0.1.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "time-locale-compat-" version "/"
+                           "time-locale-compat-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1vdcfr2hp9qh3ag90x6ikbdf42wiqpdylnplffna54bpnilbyi4i"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/khibino/haskell-time-locale-compat")
+    (synopsis "Compatibility of TimeLocale between old-locale and time-1.5")
+    (description "This Haskell package contains wrapped name module for
+TimeLocale.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here