summary refs log tree commit diff
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@suse.cz>2015-02-26 23:36:55 +0100
committerTomáš Čech <sleep_walker@suse.cz>2015-03-10 23:00:43 +0100
commitc58ed7732ac31ba3829e1bbb4342b63c84e6d44b (patch)
tree633bc48727befd952582d7a869f74024133b1a24
parent11dddd8a3e559eff21b12db46d993b07b624ab15 (diff)
downloadguix-c58ed7732ac31ba3829e1bbb4342b63c84e6d44b.tar.gz
gnu: Add enlightenment.
* gnu/packages/enlightenment.scm (enlightenment): New variable.
-rw-r--r--gnu/packages/enlightenment.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 499ea24634..4a59e67ed8 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -28,6 +28,7 @@
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages fribidi)
   #:use-module (gnu packages game-development)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
@@ -234,3 +235,40 @@ based on Enlightenment Foundation Libraries.  It supports multiple tabs, UTF-8,
 URL and local path detection, themes, popup based content viewer for non-text
 contents and more.")
     (license license:bsd-2)))
+
+(define-public enlightenment
+  (package
+    (name "enlightenment")
+    (version "0.19.4")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append
+                "http://download.enlightenment.org/rel/apps/enlightenment/enlightenment-"
+                version ".tar.gz"))
+              (sha256
+               (base32 "01pg3ng4m3vmwzzivlssdmvhf72bsvcmm3xwf45849cibllaib8v"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("dbus" ,dbus)
+       ("freetype" ,freetype)
+       ("gettext" ,gnu-gettext)
+       ("libxcb" ,libxcb)
+       ("libxext" ,libxext)
+       ("linux-pam" ,linux-pam)
+       ("xcb-util-keysyms" ,xcb-util-keysyms)))
+    (propagated-inputs
+     ;; both these inputs are present in pkgconfig file in Require section
+     `(("efl" ,efl) ; enlightenment.pc
+       ("elementary" ,elementary))) ; enlightenment.pc
+    (home-page "http://www.enlightenment.org")
+    (synopsis "Lightweight desktop environment")
+    (description
+     "Enlightenment is resource friendly desktop environment with integrated
+file manager, wide range of configuration options, plugin system allowing to
+unload unused functionality, with support for touchscreen and suitable for
+embedded systems.")
+    (license license:bsd-2)))