summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 12:05:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:06 +0200
commitc642b86e51987a7145f66d916825aedca395f604 (patch)
treefda62c0a1e5aa98737d8cf3bebbd383f471abdaa
parent63ee600a22038192de9e456c6ec6d892730e94f9 (diff)
downloadguix-c642b86e51987a7145f66d916825aedca395f604.tar.gz
gnu: Add texlive-comprehensive.
* gnu/packages/tex.scm (texlive-comprehensive): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 845db4b097..6422555ce1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7417,6 +7417,26 @@ files for changes (using an external program).")
 may encounter.")
     (license license:gpl3+)))
 
+(define-public texlive-comprehensive
+  (package
+    (name "texlive-comprehensive")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/comprehensive/")
+             (base32
+              "1pa76hkxfmms5h6y6zyg4l5wrspprhnycfdigby8302srx676vhi")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/comprehensive")
+    (synopsis "Symbols accessible from LaTeX")
+    (description
+     "This package document the symbols accessible from LaTeX.  Over 18000
+symbols are listed as a set of tables.  The tables of symbols are ordered in
+a logical way (the document begins with a frequently requested symbols list),
+the aim being to make the document a convenient way of looking up symbols.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-ctan-o-mat
   (package
     (name "texlive-ctan-o-mat")