summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 23:26:05 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:29 +0200
commitc7339e0a82dbeadf652ea377524b477ea60f8218 (patch)
tree6b3fddbd108f31cbee3c39229700d922c5ceceac
parent735c00978bc310a023b00bdf418f171dd7a40ea3 (diff)
downloadguix-c7339e0a82dbeadf652ea377524b477ea60f8218.tar.gz
gnu: Add erlang-hex-core.
* gnu/packages/erlang.scm (erlang-hex-core): New variable.
-rw-r--r--gnu/packages/erlang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 9448ba3d91..fe984f6fea 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -377,6 +377,35 @@ of reusable Erlang components.")
 arguments using the GNU getopt syntax.")
     (license license:bsd-3)))
 
+(define-public erlang-hex-core
+  (package
+    (name "erlang-hex-core")
+    (version "0.8.2")
+    (source
+     (origin
+       (method hexpm-fetch)
+       (uri (hexpm-uri "hex_core" version))
+       (sha256
+        (base32 "15fybnqxl5lzkpd8fjj1fxmj8cxcdpkxn0cvwc41cv0vxv3pw797"))))
+    (build-system rebar3-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "rebar3" "as" "test" "proper")))))))
+    (inputs
+     `(("erlang-proper" ,erlang-proper)
+       ("erlang-rebar3-proper" ,erlang-rebar3-proper)))
+    (propagated-inputs
+     `(("erlang-getopt" ,erlang-getopt)))
+    (home-page "https://github.com/hexpm/hex_core")
+    (synopsis "Reference implementation of Hex specifications")
+    (description "This package provides the reference implementation of Hex
+specifications.")
+    (license license:asl2.0)))
+
 (define-public erlang-parse-trans
   (package
     (name "erlang-parse-trans")