summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-10-15 02:00:00 +0200
commitc7ab89c6642f0e634547f4ed26eab079b31f06bc (patch)
tree84af61f8d3c8587e13af72b1191dc6ebbb812731
parent3145968e3894a691778c23cab23462a5f7a724ca (diff)
downloadguix-c7ab89c6642f0e634547f4ed26eab079b31f06bc.tar.gz
gnu: network-manager: Update to 1.44.0.
* gnu/packages/gnome.scm (network-manager): Update to 1.44.0.
[arguments]: Disable the (new) nm-cloud-setup option.
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e5e1120615..a48cbb58f3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8276,7 +8276,7 @@ users.")
     (name "network-manager")
     ;; Note: NetworkManager still follows the odd/even major version number
     ;; for development/stable releases scheme; be sure to use a stable one.
-    (version "1.42.6")
+    (version "1.44.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/NetworkManager/"
@@ -8286,7 +8286,7 @@ users.")
                                        "network-manager-meson.patch"))
               (sha256
                (base32
-                "0y82xl84dyhdkyl98y86wspiq9iy5jz23bjzc3mvrijsfz1qlf4c"))))
+                "17zvg63jjbqdw8xyc6narirvvbbv7micbn0j7dmq0bqqgmihkjpd"))))
     (build-system meson-build-system)
     (outputs '("out"
                "doc"))                  ; 8 MiB of gtk-doc HTML
@@ -8308,6 +8308,7 @@ users.")
          "-Ddhcpcanon=no"
          "-Dcrypto=gnutls"
          "-Diwd=true"
+         "-Dnm_cloud_setup=false"
          "-Dlibaudit=yes"
          "-Dqt=false"
          "-Ddocs=true"
@@ -8319,7 +8320,7 @@ users.")
                         #$output "/etc/dbus-1/system.d")
 
          (string-append "-Ddhclient=" (search-input-file %build-inputs
-                                                         "/sbin/dhclient")))
+                                                         "sbin/dhclient")))
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'patch-modprobe-path