summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-11 20:23:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-12 16:09:37 +0200
commitc8749b02500ecf90119e47b4af1bf6bb0c870ec1 (patch)
tree83c22bdaff53e61b2b0b954c4980eb881963ebde
parentb2c8d31ff673ca1714be16968c9ead9a99ae2b7b (diff)
downloadguix-c8749b02500ecf90119e47b4af1bf6bb0c870ec1.tar.gz
gnu: Add perl-mock-config.
* gnu/packages/perl-check.scm (perl-mock-config): New public variable.
-rw-r--r--gnu/packages/perl-check.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 16010b441f..98b4e392c7 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -44,6 +44,27 @@
 ;;;
 
 
+(define-public perl-mock-config
+  (package
+    (name "perl-mock-config")
+    (version "0.03")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/Mock-Config-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "06q0xkg5cwdwafzmb9rkaa305ddv7vli9gpm6n9jnkyaaxbk9f55"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/Mock-Config")
+    (synopsis "Temporarily set Config or XSConfig values")
+    (description
+     "The @code{Mock::Config} Perl module allows temporarily setting and
+overriding @code{Config} values, even for the readonly @code{XSConfig}
+implementation as used in cperl.  It does not store the mocked overrides
+lexically, just dynamically.")
+    (license artistic2.0)))
+
 (define-public perl-test2-bundle-extended
   (package
     (name "perl-test2-bundle-extended")