summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-07 16:14:47 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:27 +0200
commitc89bbc8ea219f22f24f5e5dbb8dd9aeb2fbd16da (patch)
tree1953c98317a4b72b6e8e2b73187b9f8ac0f3acc7
parenta74ece550aaccb695de0826823f5dc4d7b4e99c9 (diff)
downloadguix-c89bbc8ea219f22f24f5e5dbb8dd9aeb2fbd16da.tar.gz
gnu: Add rust-mach-o-sys-0.1.
* gnu/package/crates-io.scm (rust-mach-o-sys-0.1): New variable.
-rw-r--r--gnu/packages/crates-io.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 242140364d..57b17285d2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12075,6 +12075,24 @@ implementation of LZMA and xz stream encoding/decoding.")
      "This package provides a collection of great and ubiqutitous macros.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-mach-o-sys-0.1
+  (package
+    (name "rust-mach-o-sys")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "mach-o-sys" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "09l8p7nmzq37450x2h6nb7dzg1sk6dk36a5rkcrcy81zm21lb19y"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/fitzgen/mach_o_sys")
+    (synopsis "Bindings to the OSX mach-o system library")
+    (description "This package provides bindings to the OSX mach-o system
+library")
+  (license (list license:asl2.0 license:expat))))
+
 (define-public rust-make-cmd-0.1
   (package
     (name "rust-make-cmd")