summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-12-21 11:50:17 -0500
committerLeo Famulari <leo@famulari.name>2016-12-21 11:52:36 -0500
commitc8c385a04a01c0c9b8d70fe18fd97d6c6531caea (patch)
treef93b481059bfaaec3546bc334336562582c9813e
parentf05f5b307e0c767e4b6cfdfd3c98ce2ccb25e25f (diff)
downloadguix-c8c385a04a01c0c9b8d70fe18fd97d6c6531caea.tar.gz
Revert "gnu: curl: Update replacement to 7.52.0 [fixes CVE-2016-{9586,9952,9953}]."
The curl maintainers said this about 7.52.0:

"Attention! We will release a patch update within a few days to fix a
serious security problem found in curl 7.52.0. You may consider holding
off until then."

This message was displayed at <https://curl.haxx.se/download.html> on
2016-12-21.

This reverts commit 42366b35c3f9f8dc8b059d3369b8196a4b832c18.
-rw-r--r--gnu/packages/curl.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 3e32a5905a..790f542a52 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -40,7 +40,7 @@
 (define-public curl
   (package
    (name "curl")
-   (replacement curl-7.52.0)
+   (replacement curl-7.51.0)
    (version "7.50.3")
    (source (origin
             (method url-fetch)
@@ -121,15 +121,15 @@ tunneling, and so on.")
                                   "See COPYING in the distribution."))
    (home-page "http://curl.haxx.se/")))
 
-(define curl-7.52.0
+(define curl-7.51.0
   (package
     (inherit curl)
     (source
-      (let ((version "7.52.0"))
+      (let ((version "7.51.0"))
         (origin
           (method url-fetch)
           (uri (string-append "https://curl.haxx.se/download/curl-"
                               version ".tar.lzma"))
           (sha256
            (base32
-            "1hh9w3dwc84c84y15pwc415jfqfhjdjk45k4f5yn5j3jgi613w68")))))))
+            "0605f28m2kxjcxrcfcv1ja353gv167lwyxjc3xizqbwppdmmzvwy")))))))