summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 12:17:16 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-04 16:10:53 +0200
commitc8f49e5c704276620e83db5777d13a49726e9e80 (patch)
treeec222cc2820624353554d9dcbdabee6aee539888
parentd0326574f8c882c0b156aa1e1add21dd361527f2 (diff)
downloadguix-c8f49e5c704276620e83db5777d13a49726e9e80.tar.gz
gnu: Add trytond-google-maps.
* gnu/packages/tryton.scm (trytond-google-maps): New variable.
-rw-r--r--gnu/packages/tryton.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index c105d4fe2d..32f38d0892 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1767,6 +1767,27 @@ from the UNECE.  Supported formats are:
 information system) support to Tryton.")
     (license license:gpl3+)))
 
+(define-public trytond-google-maps
+  (package
+    (name "trytond-google-maps")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_google_maps" version))
+       (sha256
+        (base32 "1wgcnl3r1017vicbf7rkcwv2ffrhaah90hcajn3i78bywjdag6nj"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "trytond_google_maps"))
+    (native-inputs (%standard-trytond-native-inputs))
+    (propagated-inputs (list trytond trytond-party))
+    (home-page "https://docs.tryton.org/projects/modules-google-maps")
+    (synopsis "Tryton module to link addresses to Google Maps")
+    (description "The @emph{Trytond Google Maps} Tryton module adds a new URL
+field on the party addresses.  This link open the Google Maps page on the
+default browser with the map centered on the selected address.")
+    (license license:gpl3+)))
+
 (define-public trytond-incoterm
   (package
     (name "trytond-incoterm")