summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:31:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:42 +0200
commitc907fa75c742598436ffce83243000ccc77fbf2d (patch)
tree01e566d4c2be573c9e7b57b3bfa40c8e4b979ca5
parent574f53deb864f3661e136bed7347739331aefe2a (diff)
downloadguix-c907fa75c742598436ffce83243000ccc77fbf2d.tar.gz
gnu: Add texlive-pst-perspective.
* gnu/packages/tex.scm (texlive-pst-perspective): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ae888f8e63..658750a7cf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33741,6 +33741,26 @@ used both with LaTeX and PlainTeX.  A separate Perl program for generating TeX
 files from spreadsheets is available.")
     (license license:lppl)))
 
+(define-public texlive-pst-perspective
+  (package
+    (name "texlive-pst-perspective")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-perspective/"
+                   "tex/generic/pst-perspective/"
+                   "tex/latex/pst-perspective/")
+             (base32
+              "0dm7qqar0kjnc68xwhp7vn4m8bcsmzcs6qzh61ainbls7gni5aq8")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pst-perspective")
+    (synopsis "Draw perspective views using PSTricks")
+    (description
+     "The package provides the means to draw an orthogonal parallel projection
+with an arbitrarily chosen angle and a variable shortening factor.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-pst-text
   (package
     (name "texlive-pst-text")