summary refs log tree commit diff
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-06-21 07:33:37 -0700
committerLudovic Courtès <ludo@gnu.org>2023-10-21 00:27:25 +0200
commitc942f4dcaba8f44d9f89540c22825e935c5acfd1 (patch)
tree3b0005a1111fadab0e7b267d157abf59fb4c8e71
parentfb35aba10841b5d8f802cebebc8c4810698190a2 (diff)
downloadguix-c942f4dcaba8f44d9f89540c22825e935c5acfd1.tar.gz
gnu: Add river.
* gnu/packages/zig-xyz.scm (river): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/zig-xyz.scm46
1 files changed, 44 insertions, 2 deletions
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index f85fde343e..200b5c9940 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2022 Maya Tomasek <maya.tomasek@disroot.org>
 ;;; Copyright © 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,8 +26,49 @@
   #:use-module (guix build-system zig)
   #:use-module (guix gexp)
   #:use-module (gnu packages)
-  #:use-module (gnu packages zig)
-  #:use-module (gnu packages python))
+  #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages man)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages wm)
+  #:use-module (gnu packages xdisorg)
+  #:use-module (gnu packages xorg)
+  #:use-module (gnu packages zig))
+
+(define-public river
+  (package
+    (name "river")
+    (version "0.2.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/riverwm/river")
+             (commit (string-append "v" version))
+             (recursive? #t)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1nvhqs6wwisf8ama7y1y3q3nf2jm9sh5bn46z8kyds8cikm0x1vh"))))
+    (build-system zig-build-system)
+    (arguments
+     (list
+      #:zig-build-flags #~(list "-Dxwayland")   ;experimental xwayland support
+      #:zig-release-type "safe"))
+    (native-inputs (list libevdev
+                         libxkbcommon
+                         pkg-config
+                         pixman
+                         scdoc
+                         wayland
+                         wayland-protocols
+                         wlroots))
+    (home-page "https://github.com/riverwm/river")
+    (synopsis "Dynamic tiling Wayland compositor")
+    (description
+     "River is a dynamic tiling Wayland compositor with flexible
+runtime configuration.  It can run nested in an X11/Wayland session or also
+directly from a tty using KMS/DRM.")
+    (license license:gpl3)))
 
 (define-public tigerbeetle
   (package