summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 21:55:26 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:09 +0200
commitc9c6f4b543a0aaf2da6512768cf54c898fd784df (patch)
tree40b44e8effaf55f998b31c547eac4743a42aa3d2
parent71be51d5310ec47ebfe49dabefd52fab23123ad4 (diff)
downloadguix-c9c6f4b543a0aaf2da6512768cf54c898fd784df.tar.gz
gnu: Add r-progress.
* gnu/packages/cran.scm (r-progress): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fa75317e94..d88202ca5a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -475,3 +475,27 @@ quantities.")
      "Flexibly restructure and aggregate data using just two functions:
 @code{melt} and @code{cast}.  This package provides them.")
     (license license:expat)))
+
+(define-public r-progress
+  (package
+    (name "r-progress")
+    (version "1.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "progress" version))
+       (sha256
+        (base32
+         "1fxakchfjr5vj59s9sxynd7crpz97xj42438rmkhkf3rjpyspx59"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-prettyunits" ,r-prettyunits)
+       ("r-r6" ,r-r6)))
+    (home-page "https://github.com/gaborcsardi/progress")
+    (synopsis "Terminal progress bars")
+    (description
+     "This package provides configurable progress bars.  They may include
+percentage, elapsed time, and/or the estimated completion time.  They work in
+terminals, in Emacs ESS, RStudio, Windows Rgui, and the macOS R.app.  The
+package also provides a C++ API, that works with or without Rcpp.")
+    (license license:expat)))