summary refs log tree commit diff
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:23 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 22:10:28 +0100
commitcb1fe1c6905a2e40ca767035809f6b35cd35fe22 (patch)
treefc9db6cdfc7842ced9ec7a8aef5e79ef297a9bae
parent417be516def1853d2ef9bf40a31d9eba759451e9 (diff)
downloadguix-cb1fe1c6905a2e40ca767035809f6b35cd35fe22.tar.gz
gnu: Add ocaml5.0-eio-main.
* gnu/packages/ocaml.scm (ocaml5.0-eio-main): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 30c3d93eaa..3eb155b8a7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2903,6 +2903,27 @@ OCaml with fibers.")
 (define-public ocaml5.0-eio-linux
   (package-with-ocaml5.0 ocaml-eio-linux))
 
+(define ocaml-eio-main
+  (package
+    (inherit ocaml-eio)
+    (name "ocaml-eio-main")
+    (arguments `(#:package "eio_main"
+                 #:test-target "."
+                 ;; tests require network
+                 #:tests? #f))
+    (propagated-inputs
+     (list ocaml-eio
+           ocaml-eio-luv
+           ocaml-eio-linux))
+    (native-inputs
+     (list ocaml-mdx))
+    (synopsis "Eio backend selector")
+    (description "@code{Eio_main} selects an appropriate backend (e.g.
+@samp{eio_linux} or @samp{eio_luv}), depending on your platform.")))
+
+(define-public ocaml5.0-eio-main
+  (package-with-ocaml5.0 ocaml-eio-main))
+
 (define-public ocaml-lwt
   (package
     (name "ocaml-lwt")