summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-12 10:48:58 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-15 10:36:41 +0200
commitcba256f8faaa18457fc9b77e8b401f17b89bdd75 (patch)
tree45e95adae8f0bea067f2b8cccdd7b01c6a409d61
parent2e189eb89fd2d7c63ff6f364c771fd4751f86a18 (diff)
downloadguix-cba256f8faaa18457fc9b77e8b401f17b89bdd75.tar.gz
gnu: python-numpy-bootstrap: Add lapack to inputs.
* gnu/packages/python.scm (python-numpy-bootstrap)[inputs]: Add lapack to
  inputs, because OpenBLAS does not include lapack functions.
-rw-r--r--gnu/packages/python.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 232a785778..39fd90a8d1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2285,7 +2285,8 @@ writing C extensions for Python as easy as Python itself.")
     (build-system python-build-system)
     (inputs
      `(("python-nose" ,python-nose)
-       ("openblas" ,openblas)))
+       ("openblas" ,openblas)
+       ("lapack" ,lapack)))
     (native-inputs
      `(("gfortran" ,gfortran-4.8)))
     (arguments
@@ -2295,11 +2296,21 @@ writing C extensions for Python as easy as Python itself.")
         (lambda* (#:key inputs #:allow-other-keys)
           (call-with-output-file "site.cfg"
             (lambda (port)
-              (format port "[openblas]
+              (format port
+                      "[openblas]
 libraries = openblas
 library_dirs = ~a/lib
 include_dirs = ~a/include
-" (assoc-ref inputs "openblas") (assoc-ref inputs "openblas"))))
+
+[lapack]
+lapack_libs = lapack
+library_dirs = ~a/lib
+include_dirs = ~a/include
+"
+                      (assoc-ref inputs "openblas")
+                      (assoc-ref inputs "openblas")
+                      (assoc-ref inputs "lapack")
+                      (assoc-ref inputs "lapack"))))
           ;; Use "gcc" executable, not "cc".
           (substitute* "numpy/distutils/system_info.py"
             (("c = distutils\\.ccompiler\\.new_compiler\\(\\)")