summary refs log tree commit diff
diff options
context:
space:
mode:
authorCarlo Zancanaro <carlo@zancanaro.id.au>2017-01-22 13:05:54 +0800
committer宋文武 <iyzsong@member.fsf.org>2017-01-22 13:39:57 +0800
commitcba84a38054b6ff3fd88a670a8d0a591e12d24db (patch)
treec00afc8b98a57c5f0ba8cef2eae6506fc8a29bfc
parent916aafa401c5dfb8099da1ef53e24a9b5762b3a1 (diff)
downloadguix-cba84a38054b6ff3fd88a670a8d0a591e12d24db.tar.gz
gnu: Add python-qrcode.
* gnu/packages/python.scm (python-qrcode, python2-qrcode): New variables.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 398c864faa..d26053b224 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12492,3 +12492,33 @@ a file-like object from which an arbitrarly-sized key can be read.")
 
 (define-public python2-pbkdf2
   (package-with-python2 python-pbkdf2))
+
+(define-public python-qrcode
+  (package
+    (name "python-qrcode")
+    (version "5.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "qrcode" version))
+       (sha256
+        (base32
+         "0kljfrfq0c2rmxf8am57333ia41kd0snbm2rnqbdy816hgpcq5a1"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-lxml" ,python-lxml)     ; for SVG output
+       ("python-pillow" ,python-pillow) ; for PNG output
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/lincolnloop/python-qrcode")
+    (synopsis "QR Code image generator")
+    (description "This package provides a pure Python QR Code generator
+module.  It uses the Python Imaging Library (PIL) to allow for the generation
+of QR Codes.
+
+In addition this package provides a command line tool to generate QR codes and
+either write these QR codes to a file or do the output as ascii art at the
+console.")
+    (license license:bsd-3)))
+
+(define-public python2-qrcode
+  (package-with-python2 python-qrcode))