summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-11-02 09:01:36 +0000
committerMarius Bakke <mbakke@fastmail.com>2016-11-02 12:01:37 +0000
commitcbf5889fe542dafe71c6eedf9cc72673495fcc88 (patch)
treee153831db192373cb03d6effa9dcc3cf060d968b
parentac1dc6d12fb5fac57df6a42584f134c873fbc38b (diff)
downloadguix-cbf5889fe542dafe71c6eedf9cc72673495fcc88.tar.gz
gnu: curl: Update replacement to 7.51.0 [fixes CVE-2016-{8615..8625}].
* gnu/packages/curl.scm (curl)[replacement]: Update to 7.51.0.
(curl-7.50.3): Replace with ...
(curl-7.51.0): ... this.
-rw-r--r--gnu/packages/curl.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 5cd80868f7..5d92e0337c 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -40,7 +40,7 @@
 (define-public curl
   (package
    (name "curl")
-   (replacement curl-7.50.3)
+   (replacement curl-7.51.0)
    (version "7.47.0")
    (source (origin
             (method url-fetch)
@@ -125,15 +125,15 @@ tunneling, and so on.")
                                   "See COPYING in the distribution."))
    (home-page "http://curl.haxx.se/")))
 
-(define curl-7.50.3
+(define curl-7.51.0
   (package
     (inherit curl)
     (source
-      (let ((version "7.50.3"))
+      (let ((version "7.51.0"))
         (origin
           (method url-fetch)
           (uri (string-append "https://curl.haxx.se/download/curl-"
                               version ".tar.lzma"))
           (sha256
            (base32
-            "1spmk0345hq0sgpwxs8d410268lmg3wf1x9v23hxff7wxki5fm4c")))))))
+            "0605f28m2kxjcxrcfcv1ja353gv167lwyxjc3xizqbwppdmmzvwy")))))))