summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-13 11:39:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-13 11:51:28 +0200
commitcbf6017d83e094dda7f0ed96706c15997c9b0660 (patch)
tree577602b264a807cc5641ead8f1af79089f1085e4
parent141e43bd4ee536bbfbe9ec360c9f81bc9842a9fd (diff)
downloadguix-cbf6017d83e094dda7f0ed96706c15997c9b0660.tar.gz
gnu: Add r-flashclust.
* gnu/packages/cran.scm (r-flashclust): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 232e9797b7..6bf278bf7d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4295,3 +4295,24 @@ American Statistician 50, 178-180.  There are also routines implementing the
 profile plots described in Bates and Watts (1988), Nonlinear Regression
 Analysis and its Applications.")
     (license license:gpl2+)))
+
+(define-public r-flashclust
+  (package
+    (name "r-flashclust")
+    (version "1.01-2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "flashClust" version))
+       (sha256
+        (base32
+         "0l4lpz451ll7f7lfxmb7ds24ppzhfg1c3ypvydglcc35p2dq99s8"))))
+    (properties `((upstream-name . "flashClust")))
+    (build-system r-build-system)
+    (native-inputs `(("gfortran" ,gfortran)))
+    (home-page "https://cran.r-project.org/web/packages/flashClust/")
+    (synopsis "Implementation of optimal hierarchical clustering")
+    (description
+     "This package provides a fast implementation of hierarchical
+clustering.")
+    (license license:gpl2+)))