summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-06-12 16:03:43 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-08-08 22:08:24 +0200
commitccdc1690bd871a7a4dfa466087a85b9d180db903 (patch)
tree34fa547bb75519faa623e2ac3a7b9dcb11daa58a
parentd3028f5b273d50a490a790fba94f49494f0c7b4c (diff)
downloadguix-ccdc1690bd871a7a4dfa466087a85b9d180db903.tar.gz
gnu: Cython: Update to 0.28.4.
* gnu/packages/python.scm (python-cython, python2-cython): Update to 0.28.4.
[arguments]: Use invoke.
-rw-r--r--gnu/packages/python.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 082b889c2a..668143d999 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2764,14 +2764,14 @@ and is very extensible.")
 (define-public python-cython
   (package
     (name "python-cython")
-    (version "0.27")
+    (version "0.28.4")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Cython" version))
        (sha256
         (base32
-         "02y0pp1nx77b8s1mpxc6da2dccl6wd31pp4ksi9via479qcvacmr"))))
+         "0imw9s2rbrh32clbl10csnwmig9p3nzkrd2baxxxfmnrsc42pb3n"))))
     (build-system python-build-system)
     ;; we need the full python package and not just the python-wrapper
     ;; because we need libpython3.3m.so
@@ -2784,7 +2784,7 @@ and is very extensible.")
            ;; some tests require access to "$HOME/.cython"
            (lambda _ (setenv "HOME" "/tmp") #t))
          (replace 'check
-           (lambda _ (zero? (system* "python" "runtests.py" "-vv")))))))
+           (lambda _ (invoke "python" "runtests.py" "-vv"))))))
     (home-page "http://cython.org/")
     (synopsis "C extensions for Python")
     (description "Cython is an optimising static compiler for both the Python