summary refs log tree commit diff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2023-08-24 09:05:04 +0300
committerChristopher Baines <mail@cbaines.net>2023-09-12 08:36:29 +0100
commitcdddc6bc28e2026b78800533069688e510df42f2 (patch)
treefd81af0bf5fcd59dfa6d9c8cae36d600dc20a659
parent8294f45dfc849f3006ea362ce754d04c5ecf89db (diff)
downloadguix-cdddc6bc28e2026b78800533069688e510df42f2.tar.gz
gnu: guile-png: Update to 0.7.1
* gnu/packages/guile-xyz.scm (guile-png): Update to 0.7.1.
[arguments]: Update style and delete "strip" phase.
[description]: Update.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/guile-xyz.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b40079c383..01dbe9b3ad 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3856,7 +3856,7 @@ debugging code.")
 (define-public guile-png
   (package
     (name "guile-png")
-    (version "0.7.0")
+    (version "0.7.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3865,10 +3865,13 @@ debugging code.")
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "0nkim662lb48y8n5hik8rrj76600v2inwaxwnfpdny7h2j0yq1wm"))))
+                "0y65795s9bs69msqvdbq8h34n00bkfs5v1d44wz21nwdffvq6557"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+     (list
+      #:make-flags #~(list "GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
+      #:phases #~(modify-phases %standard-phases
+                   (delete 'strip))))
     (native-inputs (list autoconf
                          automake
                          pkg-config
@@ -3884,9 +3887,9 @@ debugging code.")
     (synopsis "PNG file parsing library for Guile")
     (description
      "@code{guile-png} is a GNU Guile library for working with the
-@url{https://en.wikipedia.org/wiki/PNG, PNG format}.  This library provides
-API for reading and writing PNG data, as well as some basic image processing
-filters.")
+@url{https://en.wikipedia.org/wiki/PNG, PNG format}.  This library provides API for
+reading and writing PNG data, as well as some graphic primitives and basic image
+processing filters.")
     (license license:gpl3+)))
 
 (define-public nomad