summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-03-26 12:22:47 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-26 12:23:36 +0100
commitceab612374b3eb3f6013b017454443fe47f104ef (patch)
tree2eb18bfef1633d83d4dcdf8c597b020ff9982674
parent5e00dcc89e802a36cd648e77b4c17ae676562e02 (diff)
downloadguix-ceab612374b3eb3f6013b017454443fe47f104ef.tar.gz
gnu: docker: Use disjunct temp directories for probing.
* gnu/packages/patches/docker-use-fewer-modprobes.patch: Use disjunct temp
directories for probing.
-rw-r--r--gnu/packages/patches/docker-use-fewer-modprobes.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/patches/docker-use-fewer-modprobes.patch b/gnu/packages/patches/docker-use-fewer-modprobes.patch
index 742cd60633..2779e1be5d 100644
--- a/gnu/packages/patches/docker-use-fewer-modprobes.patch
+++ b/gnu/packages/patches/docker-use-fewer-modprobes.patch
@@ -51,7 +51,7 @@ See <https://github.com/moby/moby/pull/38930>.
 -	// proc/filesystems for when overlay is supported
 -	exec.Command("modprobe", "overlay").Run()
 +	// Access overlay filesystem so that Linux loads it (if possible).
-+	mountTarget, err := ioutil.TempDir("", "supportsOverlay")
++	mountTarget, err := ioutil.TempDir("", "supportsOverlay2")
 +	if err != nil {
 +		logrus.WithField("storage-driver", "overlay2").Error("Could not create temporary directory, so assuming that 'overlay' is not supported.")
 +		return graphdriver.ErrNotSupported
@@ -71,14 +71,14 @@ See <https://github.com/moby/moby/pull/38930>.
  
 -	// Check if kernel supports xfs filesystem or not.
 -	exec.Command("modprobe", "xfs").Run()
-+        mountTarget, err := ioutil.TempDir("", "supportsOverlay")
-+        if err != nil {
++	mountTarget, err := ioutil.TempDir("", "supportsXFS")
++	if err != nil {
 +		return errors.Wrapf(err, "error checking for xfs support")
-+        } else {
-+                /* The mounting will fail--after the module has been loaded.*/
-+                defer os.RemoveAll(mountTarget)
-+                unix.Mount("none", mountTarget, "xfs", 0, "")
-+        }
++	} else {
++		/* The mounting will fail--after the module has been loaded.*/
++		defer os.RemoveAll(mountTarget)
++		unix.Mount("none", mountTarget, "xfs", 0, "")
++	}
  
  	f, err := os.Open("/proc/filesystems")
  	if err != nil {