summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-07-15 22:41:19 +0200
committerAndreas Enge <andreas@enge.fr>2013-07-15 22:41:19 +0200
commitcf2135ff4816746dbc671b08ab87cb6466077acc (patch)
tree7b4213b7ede6a7dea6d225dc5c8a611577333dfe
parentffd2093440b801e449c1b69367d86a184f183a40 (diff)
downloadguix-cf2135ff4816746dbc671b08ab87cb6466077acc.tar.gz
Add gtk+.
* gnu/packages/gtk.scm (pango): Propagate input harfbuzz.
* gnu/packages/gtk.scm (gtk+): New variable.
-rw-r--r--gnu/packages/gtk.scm41
1 files changed, 40 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 2e0a7b60b4..3776e5adc0 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -143,9 +143,10 @@ affine transformation (scale, rotation, shear, etc.)")
              (base32
               "0k7662qix7zzh7mf6ikdj594n8jpbfm25z8swz64zbm86kgk1shs"))))
    (build-system gnu-build-system)
+   (propagated-inputs
+    `(("harfbuzz" ,harfbuzz)))
    (inputs
     `(("cairo" ,cairo)
-      ("harfbuzz" ,harfbuzz)
       ("pkg-config" ,pkg-config)
       ("zlib" ,zlib)))
    (synopsis "GNOME text and font handling library")
@@ -180,3 +181,41 @@ used throughout the world.")
 in the GNOME project.")
    (license license:lgpl2.0+)
    (home-page "https://developer.gnome.org/gdk-pixbuf/")))
+
+(define-public gtk+
+  (package
+   (name "gtk+")
+   (version "2.24.20")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/gtk+/2.24/gtk+-"
+                                version ".tar.xz"))
+            (sha256
+             (base32
+              "18qdvb7nxi25hfnpmcy01p3majw9jnx83ikm263dk9rrjazvqrnc"))))
+   (build-system gnu-build-system)
+   (inputs
+    `(("atk" ,atk)
+      ("cairo" ,cairo)
+      ("gdk-pixbuf" ,gdk-pixbuf)
+      ("pango" ,pango)
+      ("pkg-config" ,pkg-config)))
+   (arguments
+    `(#:phases
+      (alist-replace
+       'configure
+       (lambda* (#:key #:allow-other-keys #:rest args)
+        (let ((configure (assoc-ref %standard-phases 'configure)))
+          ;; FIXME: re-enable tests requiring an X server
+          (substitute* "gtk/Makefile.in"
+           (("SUBDIRS = theme-bits . tests") "SUBDIRS = theme-bits ."))
+          (apply configure args)))
+      %standard-phases)))
+   (synopsis "multi-platform toolkit for creating graphical user interfaces")
+   (description
+    "GTK+, or the GIMP Toolkit, is a multi-platform toolkit for creating
+graphical user interfaces. Offering a complete set of widgets, GTK+ is
+suitable for projects ranging from small one-off tools to complete
+application suites.")
+   (license license:lgpl2.0+)
+   (home-page "http://www.gtk.org/")))