summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-09-15 16:12:35 -0400
committerMark H Weaver <mhw@netris.org>2015-09-15 16:12:35 -0400
commitd02f38f3f8203154ec92c9d4fc2785835e91d2dc (patch)
tree5ae6655773425e1c34ecd110fa41849372a9dc45
parentc136546aaa6e0dfb9539c86956285bfb0b183de4 (diff)
downloadguix-d02f38f3f8203154ec92c9d4fc2785835e91d2dc.tar.gz
gnu: gcc-toolchain: Don't try to delete OUT/bin/sh, which no longer exists.
* gnu/packages/commencement.scm (gcc-toolchain)[arguments]: Remove code that
  deletes OUT/bin/sh and OUT/bin/bash, since those files no longer exist in
  our libc package.
-rw-r--r--gnu/packages/commencement.scm8
1 files changed, 0 insertions, 8 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 006aee5f3c..56c4cefaf9 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -867,14 +867,6 @@ COREUTILS-FINAL vs. COREUTILS, etc."
                        (((names . directories) ...)
                         (union-build out directories)))
 
-                     ;; Remove the 'sh' and 'bash' binaries that come with
-                     ;; libc to avoid polluting the user's profile (these are
-                     ;; statically-linked binaries with no locale support and
-                     ;; so on.)
-                     (for-each (lambda (file)
-                                 (delete-file (string-append out "/bin/" file)))
-                               '("sh" "bash"))
-
                      (union-build (assoc-ref %outputs "debug")
                                   (list (assoc-ref %build-inputs
                                                    "libc-debug")))))))