summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-02 19:59:29 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:18 +0300
commitd12aa44d0819088a7e16ae6122f776e0d903d749 (patch)
tree0abdc33a356430dd626bd0543d412897c39839dc
parent0fb34e050bcc5512fbb5ead208d9cbbe66a5e6e4 (diff)
downloadguix-d12aa44d0819088a7e16ae6122f776e0d903d749.tar.gz
gnu: Add rust-rpassword-7.
* gnu/packages/crates-io.scm (rust-rpassword-7): New variable.
(rust-rpassword-6): Inherit from rust-rpassword-7.
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 23 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5030842f2d..62c0e7094f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -54548,23 +54548,22 @@ scenario you want to test.")
 floating-point, and complex numbers based on GMP, MPFR and MPC.")
     (license license:lgpl3+)))
 
-(define-public rust-rpassword-6
+(define-public rust-rpassword-7
   (package
     (name "rust-rpassword")
-    (version "6.0.1")
+    (version "7.2.0")
     (source (origin
               (method url-fetch)
               (uri (crate-uri "rpassword" version))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0mnrpxvai78mn9wqkqx8wp1gd280jjhn29ixd1dm84l6i2hrkw1b"))))
+                "08l3jbjwpsj6awm4lacm2bcj3cn9jhy4j6q21n68k49lmdiwyy36"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-libc" ,rust-libc-0.2)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-rtoolbox" ,rust-rtoolbox-0.0.1)
         ("rust-winapi" ,rust-winapi-0.3))))
     (home-page "https://github.com/conradkleinespel/rpassword")
     (synopsis "Read passwords in Rust console applications")
@@ -54572,6 +54571,25 @@ floating-point, and complex numbers based on GMP, MPFR and MPC.")
 console applications.")
     (license license:asl2.0)))
 
+(define-public rust-rpassword-6
+  (package
+    (inherit rust-rpassword-7)
+    (name "rust-rpassword")
+    (version "6.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "rpassword" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0mnrpxvai78mn9wqkqx8wp1gd280jjhn29ixd1dm84l6i2hrkw1b"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-libc" ,rust-libc-0.2)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-winapi" ,rust-winapi-0.3))))))
+
 (define-public rust-rpassword-5
   (package
     (inherit rust-rpassword-6)