summary refs log tree commit diff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:40 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:53 +0100
commitd13cb99e1d370ea36c19f509f5ca8f3d7a147722 (patch)
treee1bf91c9129f2a034b602e227aa772d6863b6e96
parent7513a596f9e90c6843813d8a6174335c1b618144 (diff)
downloadguix-d13cb99e1d370ea36c19f509f5ca8f3d7a147722.tar.gz
gnu: ghc-texmath: Update to 0.12.3.2.
* gnu/packages/haskell-xyz.scm (ghc-texmath): Update to 0.12.3.2.
[inputs]: Remove ghc-temporary and ghc-utf8-string.
[native-inputs]: Add ghc-temporary and ghc-utf8-string.
-rw-r--r--gnu/packages/haskell-xyz.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index cc8c273c18..abb945ab47 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13199,23 +13199,24 @@ dependency.")
 (define-public ghc-texmath
   (package
     (name "ghc-texmath")
-    (version "0.12.3.1")
+    (version "0.12.3.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://hackage.haskell.org/package/"
                                   "texmath/texmath-" version ".tar.gz"))
               (sha256
                (base32
-                "1qyiihb9h7w7074p495yd4s8dj9adz0dy865gyp822z69jvmkcki"))))
+                "1d9r3na7hmkgr0j63fs50ssll506l1wyqhw0dpap7jk0rdz8pv6n"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-syb" ,ghc-syb)
        ("ghc-network-uri" ,ghc-network-uri)
        ("ghc-split" ,ghc-split)
-       ("ghc-temporary" ,ghc-temporary)
-       ("ghc-utf8-string" ,ghc-utf8-string)
        ("ghc-xml" ,ghc-xml)
        ("ghc-pandoc-types" ,ghc-pandoc-types)))
+    (native-inputs
+     `(("ghc-temporary" ,ghc-temporary)
+       ("ghc-utf8-string" ,ghc-utf8-string)))
     (home-page "https://github.com/jgm/texmath")
     (synopsis "Conversion between formats used to represent mathematics")
     (description