summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-17 10:27:23 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-22 10:09:03 -0400
commitd22cf3a3f23c084bcf59191febd7d58a6f652bf7 (patch)
treed5c0a1a5f22af9d0fda5144c53fa92e555d5820e
parent735b83994f6f81b18d59b0c36ffa5bb5b85fb8dd (diff)
downloadguix-d22cf3a3f23c084bcf59191febd7d58a6f652bf7.tar.gz
gnu: wireshark: Update to 4.0.4.
* gnu/packages/networking.scm (wireshark): Update to 4.0.4.
[arguments]<#:phases>: Re-introduce a now succeeding test and enable parallel
tests.  Update comment.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/networking.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3fac05c411..0c55f14077 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1758,29 +1758,29 @@ of the same name.")
 (define-public wireshark
   (package
     (name "wireshark")
-    (version "4.0.3")
+    (version "4.0.4")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.wireshark.org/download/src/wireshark-"
                            version ".tar.xz"))
        (sha256
-        (base32 "04cmgvmkyvxdpfy08adxf3smklgzakrvyvb89rrr7yqaridy2lbc"))))
+        (base32 "0jz76ra86gy7r4wwb174lggnl5y29nn68l7ydw1kj1phcijrz854"))))
     (build-system cmake-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             ;; Skip test suite failing with "Program reassemble_test is not
-             ;; available" and alike errors.  Also skip test suite failing
-             ;; with "AssertionError: Program extcap/sdjournal is not
-             ;; available" error.'
+           (lambda* (#:key parallel-tests? tests? #:allow-other-keys)
              (when tests?
-               (invoke "ctest"
-                       "-E"
-                       (string-join (list "suite_unittests" "suite_extcaps")
-                                    "|"))))))
+               (invoke "ctest" "-VV"
+                       "-j" (if parallel-tests?
+                                (number->string (parallel-job-count))
+                                "1")
+                       ;; Skip the suite_extcaps.case_extcaps.test_sdjournal
+                       ;; test as it requires sdjournal (from systemd) and
+                       ;; fails.
+                       "-E" "suite_extcaps")))))
        ;; Build process chokes during `validate-runpath' phase.
        ;;
        ;; Errors are like the following: