summary refs log tree commit diff
diff options
context:
space:
mode:
authorCharlie Ritter <chewzerita@posteo.net>2018-03-12 09:36:47 -0400
committerMarius Bakke <mbakke@fastmail.com>2018-03-26 21:43:57 +0200
commitd2a507efd92c83a9b5d38b46b3fbc406beb2e8ba (patch)
tree1909e626327db4927f1e4acb675403301feabc8e
parent96e223621fa4f7c9fc1ef52915e6d1fceed5612f (diff)
downloadguix-d2a507efd92c83a9b5d38b46b3fbc406beb2e8ba.tar.gz
gnu: Add r-haven.
* gnu/packages/cran.scm (r-haven): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 001efc929d..d50289d722 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
 ;;; Copyright © 2018 Sahithi Yarlagadda <sahi@swecha.net>
 ;;; Copyright © 2018 Sandeep Subramanian <sandeepsubramanian94@gmail.com>
+;;; Copyright © 2018 Charlie Ritter <chewzeirta@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,6 +37,31 @@
   #:use-module (gnu packages statistics)
   #:use-module (gnu packages web))
 
+(define-public r-haven
+  (package
+    (name "r-haven")
+    (version "1.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "haven" version))
+       (sha256
+        (base32
+         "1fkcvsrnw8waqwggv0aydbvbi99x5kp9g78xfxj4w6s3xvdzcysz"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-forcats" ,r-forcats)
+       ("r-hms" ,r-hms)
+       ("r-rcpp" ,r-rcpp)
+       ("r-readr" ,r-readr)
+       ("r-tibble" ,r-tibble)))
+    (home-page "https://haven.tidyverse.org")
+    (synopsis "Import and Export 'SPSS', 'Stata' and 'SAS' Files")
+    (description
+     "This package lets you mport foreign statistical formats into R via the
+embedded @url{https://github.com/WizardMac/ReadStat,ReadStat} C library.")
+    (license license:expat)))
+
 (define-public r-ape
   (package
     (name "r-ape")