summary refs log tree commit diff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:20:00 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:33 +0000
commitd2a64c84a92f6a0b46aaaf74b838a208ecce9d9d (patch)
tree333dd844b3b39388c2856b5077605e545280c328
parent62d3b9092536ab7f7717394880e99565eda19482 (diff)
downloadguix-d2a64c84a92f6a0b46aaaf74b838a208ecce9d9d.tar.gz
gnu: Add go-github-com-go-playground-assert-v2.
* gnu/packages/golang-check.scm (go-github-com-go-playground-assert-v2):
New variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: I18a67488291313c18a8e973614d78b6344d4dc45
-rw-r--r--gnu/packages/golang-check.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 5df3d9ccec..4874e0c9ae 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -755,6 +755,23 @@ reformat the source code, it only prints out style mistakes.")
 custom assertions to be used alongside native Go testing.")
     (license license:expat)))
 
+(define-public go-github-com-go-playground-assert-v2
+  (package
+    (inherit go-gopkg-in-go-playground-assert-v1)
+    (name "go-github-com-go-playground-assert-v2")
+    (version "2.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/go-playground/assert")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "13mb07dxhcy9ydqbracnrpfj682g6sazjpm56yrlbn2jc1yfy44c"))))
+    (arguments
+     (list #:import-path "github.com/go-playground/assert/v2"))))
+
 (define-public go-honnef-co-go-tools
   (package
     (name "go-honnef-co-go-tools")