summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-07-03 19:03:09 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:30 +0200
commitd37baa4bcff493510322f3ebb88410cafe94daea (patch)
tree76e719c497053a7c5c0e562079e45c3b755f80dd
parentc71bc563f2087d81f16ebd186b72f96055c251d4 (diff)
downloadguix-d37baa4bcff493510322f3ebb88410cafe94daea.tar.gz
gnu: Add erlang-proper.
* gnu/packages/erlang.scm (erlang-proper): New variable.
-rw-r--r--gnu/packages/erlang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index df822d5466..3c6ee9038a 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -465,6 +465,32 @@ specifications.")
 Erlang.")
     (license license:asl2.0)))
 
+(define-public erlang-proper
+  (package
+    (name "erlang-proper")
+    (version "1.4.0")
+    (source
+      (origin
+        (method hexpm-fetch)
+        (uri (hexpm-uri "proper" version))
+        (sha256
+          (base32 "1b0srk0swbns6807vxwhj1hfrql7r14arysaax99kvl12f4q3qci"))))
+    (build-system rebar3-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'disable-covertool
+           (lambda _
+             (substitute* "rebar.config"
+               (("\\{plugins, \\[covertool\\]\\}\\." _) "")))))))
+    (home-page "https://proper-testing.github.io/")
+    (synopsis "QuickCheck-inspired property-based testing tool for Erlang")
+    (description "PropEr is a tool for the automated, semi-random,
+property-based testing of Erlang programs.  It is fully integrated with
+Erlang's type language, and can also be used for the model-based random
+testing of stateful systems.")
+    (license license:gpl3+)))
+
 (define-public erlang-providers
   (package
     (name "erlang-providers")