summary refs log tree commit diff
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-14 22:57:38 +0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-23 09:50:06 +0200
commitd41d60b6089a3539971355705177413a2ecea319 (patch)
tree04d7c1c2ed388ce4f4eee923974efceb9782166b
parent9eb37dd1959130c6fa6e27cde6fb7f136bac0a24 (diff)
downloadguix-d41d60b6089a3539971355705177413a2ecea319.tar.gz
gnu: Add emacs-zeno-theme.
* gnu/packages/emacs-xyz.scm (emacs-zeno-theme): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 316ab04900..e5c7436d0d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6579,6 +6579,31 @@ detecting specific uses of Ruby, e.g. when using rails, and using a
 appropriate console.")
     (license license:gpl3+)))
 
+;; Package has no release.  Version is extracted from "Version:" keyword in
+;; main file.
+(define-public emacs-zeno-theme
+  (let ((commit "70fa7b7442f24ea25eab538b5a22da690745fef5")
+        (revision "0"))
+    (package
+      (name "emacs-zeno-theme")
+      (version (git-version "1.0.2" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/zenobht/zeno-theme")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "10v6yf9c5qdsxrp6rk1n1xkv4byyfkinsikskdb2apjg05cx2273"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/zenobht/zeno-theme")
+      (synopsis "Dark theme using different shades of blue for Emacs")
+      (description
+       "This package provides a dark theme using different shades of blue for
+Emacs, inspired by @code{Dracula} theme.")
+      (license license:gpl3+))))
+
 (define-public emacs-zig-mode
   (let ((commit "dbc648f5bca8f3b9ca2cc7827f326f5530115144")
         (revision "0"))