summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-24 09:41:04 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:56 -0500
commitd42a0f10e750905adf49bc03cde8c20e59636afd (patch)
treeed87145454164d999be4aa60cd58eb4fe54e697a
parent048c98b5af9a79ebd592f7964e2456238e06a087 (diff)
downloadguix-d42a0f10e750905adf49bc03cde8c20e59636afd.tar.gz
gnu: python-tblib: Do not set PYTHONPATH.
* gnu/packages/python-xyz.scm (python-tblib)
[phases]{check}: Do not set PYTHONPATH.
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 0 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b5432815c0..c4d5607554 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12311,12 +12311,6 @@ module in Python 3.5 and later.")
        (modify-phases %standard-phases
          (replace 'check
            (lambda _
-             ;; Upstream runs tests after installation and the package itself
-             ;; resides in a subdirectory. Extend PYTHONPATH so it will be
-             ;; found.
-             (setenv "PYTHONPATH"
-                     (string-append (getcwd) "/build/lib:"
-                                    (getenv "PYTHONPATH")))
              (invoke "py.test" "-vv" "tests" "README.rst"))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)