summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-30 20:33:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-30 20:59:35 +0300
commitd473d8ebdb90a2dfddc60dc6a27d40e6bf969cfe (patch)
tree7f286c7e470125a39d3467fbd0c752278cd38102
parent6f2bdd4e6b71a83d9d6963d9643a5ad848c06b9d (diff)
downloadguix-d473d8ebdb90a2dfddc60dc6a27d40e6bf969cfe.tar.gz
gnu: x265: Enable assembly on for some arm build phases.
* gnu/packages/video.scm (x265)[arguments]: Enable assembly for
armhf-linux. Only disable assembly for aarch64-linux when building the
10-bit or 12-bit libraries.
-rw-r--r--gnu/packages/video.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4fef8a01c4..40c31cdaec 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1223,9 +1223,6 @@ on the Invidious instances only as a fallback method.")
        #:configure-flags
          ;; Ensure position independent code for everyone.
          (list "-DENABLE_PIC=TRUE"
-               ,@(if (target-arm?)
-                     '("-DENABLE_ASSEMBLY=OFF")
-                     '())
                (string-append "-DCMAKE_INSTALL_PREFIX="
                               (assoc-ref %outputs "out")))
        #:phases
@@ -1246,6 +1243,9 @@ on the Invidious instances only as a fallback method.")
              (with-directory-excursion "../build-12bit"
                (apply invoke
                  "cmake" "../source"
+                 ,@(if (target-aarch64?)
+                     '("-DENABLE_ASSEMBLY=OFF")
+                     '())
                  "-DHIGH_BIT_DEPTH=ON"
                  "-DEXPORT_C_API=OFF"
                  "-DENABLE_CLI=OFF"
@@ -1263,6 +1263,9 @@ on the Invidious instances only as a fallback method.")
              (with-directory-excursion "../build-10bit"
                (apply invoke
                  "cmake" "../source"
+                 ,@(if (target-aarch64?)
+                     '("-DENABLE_ASSEMBLY=OFF")
+                     '())
                  "-DHIGH_BIT_DEPTH=ON"
                  "-DEXPORT_C_API=OFF"
                  "-DENABLE_CLI=OFF"