summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-14 16:55:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-14 17:07:20 +0300
commitd521ad06e0fa7743a25a37f92059e8d4f607a8d9 (patch)
treec18e8de4729bb0c3b16733d18c947750fafaa62c
parentca8c7a36dfbefd66841a2a6df4c9e44ba525c3e0 (diff)
downloadguix-d521ad06e0fa7743a25a37f92059e8d4f607a8d9.tar.gz
gnu: yt-dlp: Only build with pandoc on supported systems.
* gnu/packages/video.scm (yt-dlp)[arguments]: Adjust custom
'build-generated-files phase to adjust to the presence of pandoc.
[native-inputs]: Make explicit list. Only include pandoc on supported
systems.
-rw-r--r--gnu/packages/video.scm27
1 files changed, 19 insertions, 8 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 1fec5da40d..0016877033 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2509,12 +2509,17 @@ YouTube.com and many more sites.")
                   (("\\.get_param\\('ffmpeg_location'\\)" match)
                    (format #f "~a or '~a'" match (which "ffmpeg"))))))
             (replace 'build-generated-files
-              (lambda _
-                (invoke "make"
-			"PYTHON=python"
-			"yt-dlp"
-			"yt-dlp.1"
-			"completions")))
+              (lambda* (#:key inputs #:allow-other-keys)
+                (if (assoc-ref inputs "pandoc")
+                  (invoke "make"
+                          "PYTHON=python"
+                          "yt-dlp"
+                          "yt-dlp.1"
+                          "completions")
+                  (invoke "make"
+                          "PYTHON=python"
+                          "yt-dlp"
+                          "completions"))))
             (replace 'fix-the-data-directories
               (lambda* (#:key outputs #:allow-other-keys)
                 (let ((prefix (assoc-ref outputs "out")))
@@ -2534,8 +2539,14 @@ YouTube.com and many more sites.")
                       python-mutagen
                       python-pycryptodomex
                       python-websockets)))
-    (native-inputs (modify-inputs (package-native-inputs youtube-dl)
-                     (append pandoc python-pytest)))
+    (native-inputs
+     (append
+       ;; To generate the manpage.
+       (if (member (%current-system)
+                   (package-transitive-supported-systems pandoc))
+         (list pandoc)
+         '())
+       (list python-pytest zip)))
     (description
      "yt-dlp is a small command-line program to download videos from
 YouTube.com and many more sites.  It is a fork of youtube-dl with a