summary refs log tree commit diff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-04-10 13:34:17 +0100
committerChristopher Baines <mail@cbaines.net>2020-05-03 11:17:48 +0100
commitd5aee5003422c1cc4f3adfe016a24cc1b9c35881 (patch)
treef5f233a1869e590570911eb0a710ecd27200b2b4
parenta5cf52d3aa31717a8ae0c2cbbc4b848266ed7818 (diff)
downloadguix-d5aee5003422c1cc4f3adfe016a24cc1b9c35881.tar.gz
gnu: Add bchoppr.
* gnu/packages/music.scm (bchoppr): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/music.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1e56154854..b653b96906 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1162,6 +1162,28 @@ complete studio.")
 with a selectable pattern matrix size.")
     (license license:gpl3+)))
 
+(define-public bchoppr
+  (package
+    (inherit bsequencer)
+    (name "bchoppr")
+    (version "1.4.2")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/sjaehn/BChoppr.git")
+               (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "1ympx0kyn3mkb23xgd44rlrf4qnngnlkmikz9syhayklgax7ijgm"))))
+    (synopsis "Audio stream-chopping LV2 plugin")
+    (description "B.Choppr cuts the audio input stream into a repeated
+sequence of up to 16 chops.  Each chop can be leveled up or down (gating).
+B.Choppr is the successor of B.Slizr.")
+    (home-page "https://github.com/sjaehn/BChoppr")
+    (license license:gpl3+)))
+
 (define-public solfege
   (package
     (name "solfege")