summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-27 10:51:22 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:52 +0200
commitd5ce6eae28b07e3c6328729f9a7a4efcc3383a15 (patch)
tree699d8f1417b10511d8fdddd7f2fbefe555b33566
parenta13d29f0a42bf7f252b2adb987f46d9e1f07d5aa (diff)
downloadguix-d5ce6eae28b07e3c6328729f9a7a4efcc3383a15.tar.gz
gnu: rust-psl-2: Update to 2.1.13.
* gnu/packages/crates-io.scm (rust-psl-2): Update to 2.1.13.
[arguments]: Remove phase adjusting the version of the rspec dependency.

Change-Id: I9cb637b23b5f9a454b10d9420c2d765c68494a57
-rw-r--r--gnu/packages/crates-io.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4c8994d9fc..ac0ea7aa95 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -59014,7 +59014,7 @@ using protobuf-parser.")
 (define-public rust-psl-2
   (package
     (name "rust-psl")
-    (version "2.0.48")
+    (version "2.1.13")
     (source
      (origin
        (method url-fetch)
@@ -59022,20 +59022,14 @@ using protobuf-parser.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "0a2d3z6gi7bwsi4xr6m3kq44wxyr81yqr5z76afv8kfxsc8p1nxh"))))
+         "1g21gwhjzsz2jp2c4y6qg74p49vgiida98lg8yzqxdcx087rnnzy"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-psl-types" ,rust-psl-types-2))
        #:cargo-development-inputs
-       (("rust-rspec", rust-rspec-1))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-version-requirements
-           (lambda _
-             (substitute* "Cargo.toml"
-               (("1.0.0") ,(package-version rust-rspec-1))))))))
+       (("rust-rspec" ,rust-rspec-1))))
     (home-page "https://github.com/addr-rs/psl")
     (synopsis "Extract root domain and suffix")
     (description "This package extracts root domain and suffix from a domain