summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-11 16:53:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:28 +0300
commitd65858640f16aaca35428ba01651011900d4725b (patch)
tree68106981d79b0b7fa460d9b0dbc8a00f1a08e420
parent06252c397799d3725e91e6f3dee920a15629489c (diff)
downloadguix-d65858640f16aaca35428ba01651011900d4725b.tar.gz
gnu: Add rust-hex-literal-0.4.
* gnu/packages/crates-io.scm (rust-hex-literal-0.4): New variable.
(rust-hex-literal-0.3): Inherit from rust-hex-literal-0.4.
-rw-r--r--gnu/packages/crates-io.scm31
1 files changed, 22 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c6743984d5..6ad2cc0dcd 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -27432,8 +27432,29 @@ hexadecimal representation.")
        (sha256
         (base32 "1ajkw40qzn2ygnqjj9w584f6l31wi318258n84pn2hax8la2i8nn"))))))
 
+(define-public rust-hex-literal-0.4
+  (package
+    (name "rust-hex-literal")
+    (version "0.4.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "hex-literal" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0iny5inkixsdr41pm2vkqh3fl66752z5j5c0cdxw16yl9ryjdqkg"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/RustCrypto/utils")
+    (synopsis
+     "Convert hexadecimal string to byte array at compile time")
+    (description
+     "Procedural macro for converting hexadecimal string to byte array at
+compile time.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-hex-literal-0.3
   (package
+    (inherit rust-hex-literal-0.4)
     (name "rust-hex-literal")
     (version "0.3.3")
     (source
@@ -27444,15 +27465,7 @@ hexadecimal representation.")
         (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "0nzljsyz9rwhh4vi0xs9ya4l5g0ka754wgpy97r1j3v42c75kr11"))))
-    (build-system cargo-build-system)
-    (home-page "https://github.com/RustCrypto/utils")
-    (synopsis
-     "Convert hexadecimal string to byte array at compile time")
-    (description
-     "Procedural macro for converting hexadecimal string to byte array at
-compile time.")
-    (license (list license:asl2.0 license:expat))))
+         "0nzljsyz9rwhh4vi0xs9ya4l5g0ka754wgpy97r1j3v42c75kr11"))))))
 
 (define-public rust-hex-literal-0.2
   (package