summary refs log tree commit diff
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-04-30 16:33:06 +0200
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-04-30 16:34:36 +0200
commitd80ee44237ac14f26d785c279b73610ea9d5f2d0 (patch)
tree6d830283cde5676b8b247ec5deee0e9feafda989
parent7e81a761e7c4843c016818bbf1637af9047e2028 (diff)
downloadguix-d80ee44237ac14f26d785c279b73610ea9d5f2d0.tar.gz
gnu: lilv: Set rpath via LDFLAGS.
Fixes <http://bugs.gnu.org/20040>.

* gnu/packages/audio.scm (lilv): Add a pre-configure phase setting $LDFLAGS to
  set the rpath to $out/lib.
-rw-r--r--gnu/packages/audio.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 593d47d7a1..c5c1a77b2f 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -713,7 +713,16 @@ implementation of the Open Sound Control (OSC) protocol.")
               (base32
                "0aj2plkx56iar8vzjbq2l7hi7sp0ml99m0h44rgwai2x4vqkk2j2"))))
     (build-system waf-build-system)
-    (arguments `(#:tests? #f)) ; no check target
+    (arguments
+     `(#:tests? #f ; no check target
+       #:phases
+       (modify-phases %standard-phases
+         (add-before
+          'configure 'set-ldflags
+          (lambda* (#:key outputs #:allow-other-keys)
+            (setenv "LDFLAGS"
+                    (string-append "-Wl,-rpath="
+                                   (assoc-ref outputs "out") "/lib")))))))
     ;; required by lilv-0.pc
     (propagated-inputs
      `(("serd" ,serd)