summary refs log tree commit diff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:19:57 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:33 +0000
commitd86c93c9cbe522a20eca671f7991d7ade10b6331 (patch)
tree37a04c99483e22ecfbbcb522b3ed294794f067cf
parent4a8db1ec82591730da578b72f09d19ee2ed18a7c (diff)
downloadguix-d86c93c9cbe522a20eca671f7991d7ade10b6331.tar.gz
gnu: go-github-com-goccy-go-json: Update to 0.10.2.
* gnu/packages/golang-web.scm (go-github-com-goccy-go-json): Update to
0.10.2.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-web.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 673d2c2587..c97d775fff 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -646,7 +646,7 @@ Encryption, JSON Web Signature, and JSON Web Token standards.")
 (define-public go-github-com-goccy-go-json
   (package
     (name "go-github-com-goccy-go-json")
-    (version "0.9.10")
+    (version "0.10.2")
     (source
      (origin
        (method git-fetch)
@@ -655,15 +655,14 @@ Encryption, JSON Web Signature, and JSON Web Token standards.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1bg8p4c6r8r0kixdxv2m8xmdsmb1zl5sd8czswpccldjk3c358wp"))
-       (modules '((guix build utils)))
-       (snippet '(delete-file-recursively "benchmarks"))))
+        (base32 "1krid2hlvs808jl9zmv7m6zx92samc60gymhwr2mwwykicwbnks8"))))
     (build-system go-build-system)
     (arguments
      '(#:import-path "github.com/goccy/go-json"))
     (home-page "https://github.com/goccy/go-json")
     (synopsis "JSON encoder/decoder in Go")
-    (description "Fast JSON encoder/decoder compatible with encoding/json for Go.")
+    (description
+     "Fast JSON encoder/decoder compatible with encoding/json for Go.")
     (license license:expat)))
 
 (define-public go-github-com-google-go-github