summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-07 18:51:20 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:18:57 +0000
commitd8c8cfac7a4728f70662ffb1b8d2b2a2aef29f0e (patch)
tree9df549d09cef3435bc59ce0db2937fd5f671bdc6
parent20c1bd6e9e318bfbe4ad6fe926b42a159ca4f9ae (diff)
downloadguix-d8c8cfac7a4728f70662ffb1b8d2b2a2aef29f0e.tar.gz
gnu: go-github-com-mreiferson-go-options: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mreiferson-go-options): Move
from here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: Ia5cf19a48812b56b0b38ed80246a65c345454c79
-rw-r--r--gnu/packages/golang-xyz.scm24
-rw-r--r--gnu/packages/golang.scm23
2 files changed, 24 insertions, 23 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a75ae4c066..764a894a63 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
 ;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
+;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
 ;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;;
@@ -248,6 +249,29 @@ Domain Name Service}.  The API follows the less-is-more principle, by
 presenting a small interface.")
     (license license:bsd-3)))
 
+(define-public go-github-com-mreiferson-go-options
+  (package
+    (name "go-github-com-mreiferson-go-options")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mreiferson/go-options")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1pxs9ybrh196qy14ijn4zn51h2z28lj31y6vxrz2xxhgvpmfmxyl"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/mreiferson/go-options"))
+    (home-page "https://github.com/mreiferson/go-options")
+    (synopsis "Go package to structure and resolve options")
+    (description
+     "The @code{options} Go package resolves configuration values set via
+command line flags, config files, and default struct values.")
+    (license license:expat)))
+
 (define-public go-github-com-nats-io-nats-go
   (package
     (name "go-github-com-nats-io-nats-go")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9cac55bb12..fc13413420 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5516,29 +5516,6 @@ trivial @command{big.Int} encoding benchmark results in 6 times faster
 encoding and 8 times faster decoding.")
       (license license:expat))))
 
-(define-public go-github-com-mreiferson-go-options
-  (package
-    (name "go-github-com-mreiferson-go-options")
-    (version "1.0.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/mreiferson/go-options")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1pxs9ybrh196qy14ijn4zn51h2z28lj31y6vxrz2xxhgvpmfmxyl"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/mreiferson/go-options"))
-    (home-page "https://github.com/mreiferson/go-options")
-    (synopsis "Go package to structure and resolve options")
-    (description
-     "The @code{options} Go package resolves configuration values set via
-command line flags, config files, and default struct values.")
-    (license license:expat)))
-
 (define-public go-github-com-mreiferson-go-svc
   ;; NSQ specific fork of github.com/judwhite/go-svc, as Guix go build system
   ;; does not support go.mod with `replace' statement.