summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:36:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:46 +0200
commitd90ecfed35f94ef508e06ec7df6c4403a231c686 (patch)
tree124cc7096849baa67f1e44b4fb1fd0733fa03b26
parentd6c360c62ff87f06f2ed857249d589c54b7daf2a (diff)
downloadguix-d90ecfed35f94ef508e06ec7df6c4403a231c686.tar.gz
gnu: Add texlive-pst-tree.
* gnu/packages/tex.scm (texlive-pst-tree): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f7b0859830..4351cc6f39 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34225,6 +34225,26 @@ with various fillings for the body of the lines.")
 packages.")
     (license license:lppl)))
 
+(define-public texlive-pst-tree
+  (package
+    (name "texlive-pst-tree")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-tree/"
+                   "tex/generic/pst-tree/"
+                   "tex/latex/pst-tree/")
+             (base32
+              "1vznc4qyjpnni3smdxlpqi7h3qxd13kv5pigvlly0zq676n6gw8n")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pst-tree")
+    (synopsis "Trees, using PSTricks")
+    (description
+     "@code{pst-tree} defines a macro \\pstree that offers a structured way of
+joining nodes created using @code{pst-node} in order to draw trees.")
+    (license license:lppl)))
+
 (define-public texlive-marginnote
   (package
     (name "texlive-marginnote")